Spitfire Symphony Orchestra – Now available as an all-in-one plugin

Spitfire Scoring Professional

The full ensemble

  • Overview
  • Listen
  • Walkthrough
  • What's included
  • Tech specs
  • Spitfire Scoring Professional Cinemascope Press

    The full ensemble

    Bringing together five of our most popular products, Spitfire Scoring Professional is designed for professional film composers. Albion One and Spitfire Solo Strings complement each other perfectly – balancing cinematic power and nuance. Ólafur Arnalds Chamber Evolutions adds a touch of magic to your compositions, and helps you quickly create long passages of spellbinding music. Created for Blue Planet II, Orchestral Swarm is a collaboration with Hans Zimmer’s music production company Bleeding Fingers Music. This library gives your compositions a liquid dynamic that dances along to the picture. Finally, Hans Zimmer Percussion massively expands on the percussion within Albion One - offering monumental levels of depth and power for epic cinematic moments.

    Compatible with NKS

    What's included

    Listen to Spitfire Scoring Professional

    Features Albion One

    Features Orchestral Swarm

    Olafur Arnalds' studio

    For your film scoring journey

    Videos

    Tech specs

    Mac system requirements

    Mac OS X 10.10 or later

    Minimum: 2.8GHz i5 minimum (quad-core), 8GB RAM

    Recommended: 2.8GHz I7 (six-core), 16GB RAM

    Machine must be connected to the internet during install

    32-bit DAWs not supported


    PC system requirements

    Windows 7, Windows 8, or Windows 10 (latest Service Pack, 32/64-bit)

    Minimum: Intel 2.8 GHz i5 (quad-core) or AMD Ryzen 5

    Recommended: Intel 2.8 GHz i7 (six-core) or AMD R7 2700

    Machine must be connected to the internet during install

    32-bit DAWs not supported


    File size

    ~141449 samples

    282.7 GB uncompressed .WAV

    167.7 GB download size

    335.80 GB disk space required during install

    Too large to download? Choose hard drive delivery at checkout


    Kontakt player

    Kontakt Full or Kontakt Player 5.6.8 or higher